ant design pro v5 获取动态菜单与基于角色权限管理视频教程 准备更新中

世界上最伟大的投资就是投资自己的教育

6 条回复
  • 🔆 · 道祖
    🔆 · 道祖 #1

    等待更新...

    我在升级antd v4的时候直接使用 yarn create umi 进行的重建,在创建时会提示是否使用antd4

    如果从umi ui中创建项目的话依然使用的旧版本,但尝试更新v4后大面积报错,使用官方推荐的“从 v3 到 v4”的教程后无效。

  • 求知小风 · 元婴

    坑啊,更新不了,代价太高,那官方工具还不好使,还是直接使用第四版本的吧

  • 🔆 · 道祖
    🔆 · 道祖 #3

    代价是真的高,昨天弄了很久都没弄好。
    v3 到 v4这个过渡阶段感觉很乱,尤其体现在ant design pro v4
    Block使用的是antd4,项目用的是antd3,手动升级,不是依赖找不到就是语法错误。(执行语法更新后也会出问题)

    建议直接使用 yarn create umi 创建带有antd4的ant design pro v4项目比较舒服点😂
  • 求知小风 · 元婴

    重新来吗,代价也不小呀 😂

  • 求知小风 · 元婴

    不过可以考虑下,好像也没多少工作量

  • 🔆 · 道祖
    🔆 · 道祖 #6

    重新来的,基本上都是复制粘贴改改语法

© 汕尾市求知科技有限公司 | 关注我们 | 在线学员:1119

粤公网安备 44152102000088号 | 粤ICP备19038915号

Top